« 【PC】 理想のPC環境を手に入れた | トップページ | 【Venue 8 Pro】 LTE化完了 »

【Venue 8 Pro】 LTE化に挑戦(中)

少し前の「訳あり」についてですが、それはVenue 8 Pro(以後V8P)のLTE化です。

きっかけは某大型掲示板。
ME906J+みねおでLTE化できたとの報告があり、それなら私も!と思ったことにあります。
だって3Gだと艦こ・・・いや、なんでもない。

それはさておき、掲示板を見ている限り、LTE化の道のりは結構険しそうです。
ドライバが乗らない、カードを認識しない、V8Pが不調に陥る、最悪初期化の繰り返しと、何だかとてもメンドくさそうです。
IS11S(Xperia acro)のroot化以上にハードルが高そう(´・ω・`)

■実装編■

20150121_00_1_r

これがHuawei ME906Jです。
再生屋さんから購入しました。

しかも2枚w

何でまた?と聞かれたら、上手く動かなかった場合の保証ということで。
原因が通信モジュールの個体差によるものなのか?V8Pの個体差によるものなのか?の切り分けの判断のためと、下手な鉄砲数撃ちゃあたる的な発想です。
原因がわかれば、返品の理由にも書けますしね。

V8Pの裏蓋を開けたらバッテリーコネクタを引っこ抜いて、Sierraのモジュールと交換します。

20150121_00_2_r

これと

20150121_00_3

交換します。

アンテナ線のMAINとAUXがテレコになっている点に注意です。

20150121_01

実装直後はこんな感じ。
見事なまでの「!」です。

■ドライバ編 1日目■

ME906Jのドライバは、Huawei社のサイトにも無ければ、日本代理店(?)の加賀電子のサイトにもありません。
が、某大型掲示板の先人がダウンロード先のリンクを貼り付けてくれているので、今回はそれを使用します。

ドライバにはインストーラが付属していますが、単にC:\Program Files配下に展開するだけのものなのか、自動的に適用はしてくれませんでした。
やむなく「!」の全てに対し、手動でドライバを適用して行きます。

やれコード10だの、やれプラットフォームが違うだのと怒られつつ、しこしことドライバを適用し続けた結果、

20150121_02

これって良い感じじゃね!?(;゚∀゚)=3

と思ったのも束の間。
モバイルブロードバンドとして認識してくれませんでした(´・ω・`)
netshでも「無いよバーカ」と返されるところを見ると、そもそもデバイスとして正常に機能していないようです。
デバイスマネージャ的には「正常」なんだけどなぁ・・・

しばらくドライバの取っ替え引っ替えを繰り返しましたが拉致があかないってことで、最終手段のV8P初期化決定・・・

■ドライバ編 2日目■

OSのリカバリとWindowsUpdateが完了したので、ドライバとの格闘再開です。

20150122_01

現状はこんな感じです。
初期化後は「Huawei Mobile」っぽいのが一つだけ「!」で表示され、GPSだのなんだのが綺麗になくなっていました。
そこで、「ユニバーサルシリアルバス」の項にある「USBモバイルブロードバンドネットワークアダプターモジュール」を、Huaweiドライバに含まれる「USB Composit device」に変更した結果が↑。
「USBモバイルブロードバンドネットワークアダプタモジュール」がキモなのかも知れませんね。

ここからドライバを適用して行くわけですが、

20150122_02_2

20150122_03

前回と異なり、

20150122_05

20150122_06

エラーも出ず、

20150122_08

20150122_09

なんかトントン拍子なんですけど!

20150122_12

一回蹴られましたが、

20150122_14_2

概ね順調に行き、

20150122_15

とても綺麗な状態に。

前回は「互換性のあるデバイス」を選ぶと即エラーだったくせに、今回はむしろそれを選ぶだけという簡単なお仕事でした。
やったぜ。

のように思えて、実は今回もモバイルブロードバンドとして認識していないんですけどね(ノ∀`)
前回同様、netshコマンド叩いても同じ。
デバイスマネージャ的には「正常」なのも同じ。

もう一回初期化とか、違うドライバを探してネット徘徊とかメンドくせーんで、ここは一つ、もう一枚の方を試してみましょう。

■ドライバ編 3日目■

すると、

20150123_01_2

なんかおかしくなってね?

二枚目のME906Jに換えてOSを起動したところ、さっきまでズラズラ~と並んでいたGPSだのなんだのが綺麗に消え去り、「HUAWEI Mobile Connect - 3G Network Card」もWindows標準ドライバへと書き換わる始末。

明らかに悪化している感じ。

が、

20150123_02_2

な、なんだt

モバイルネットワークとして認識されてんじゃん!
しかも、「JP DOCOMO」キタコレ!

20150123_04_2

netshでもしっかり表示されたし。

悪化どころか大きく前進してますよ、これ。
結論として、1枚目のモジュールはぷち不良品 or 相性問題が原因で、ドライバがちゃんと適用されたように見えて、実はそれは表向きだけだったということかも知れません。
で、2枚目のモジュールは正常品なので、勝手に適合ドライバが適用されたってことかと。

くう・・・
あの苦労は一体なんだったのか・・・?(ノ∀`)

ちなみに今の状態は、

20150123_011

こんな感じです。
1枚目の試行錯誤時とは大きく異なります。

肝心の「HUAWEI Mobile Broadband Module」はというと、

20150123_03_2

こんな感じです。
1枚目+ドライバの時は、「詳細設定」タブが出たり出なかったりで、出ても内容がおかしかったんですよねぇ。

なんにせよ、これでLTE化も大詰め・・・と言いたいところですが、実はこの後100%スリープ死するようになりまして(ノ∀`)
再起動でも高確率で死にます。
ですからWindowsUpdateでも再起動で死にます。

艦これやりつつ6時間くらい試行錯誤していると、突然スリープ死が起きなくなりました。
イマイチ原因はハッキリしていないのですが、WLANのドライバをアンインストールし、その後再インストールってのが効いたようです。
WLANのドライバそのものが悪かったというより、Huaweiのドライバとの相性なのかも知れませんね。

後はみねおSIMを待つだけです。

【2016/7/25追記】

訳あってWindows10をクリーンインストールすることになり、またもやME906Jのところで躓きましたよ(;´Д`)
で、あれこれ試行錯誤した末、↓の手順を踏む必要があることがわかりました。

  1. Huaweiのドライバをインストール(見つけられない人用
  2. デバイスマネージャを起動し、「ユニバーサル シリアル バス コントローラ」の「USB composite device」を「USBモバイルブロードバンドネットワークアダプタモジュール」に変更
  3. ビックリマークのセンサー類には1のインストールフォルダのドライバを適用
  4. Huaweiのドライバをアンインストール
  5. 端末再起動

やっぱり行き当たりばったりはダメねw
ちなみにモバイル通信にHuaweiのドライバを使うと、再起動やシャットダウン時にエラー吹いたり、画面がまっ黒になってから完全に落ちるまでにとんでもなく時間が掛かったり、それはもう絶不調に陥るのでご注意を。

|

« 【PC】 理想のPC環境を手に入れた | トップページ | 【Venue 8 Pro】 LTE化完了 »

Venue 8 Pro」カテゴリの記事

コメント

コメントを書く



(ウェブ上には掲載しません)




トラックバック

この記事のトラックバックURL:
http://app.cocolog-nifty.com/t/trackback/109943/61034762

この記事へのトラックバック一覧です: 【Venue 8 Pro】 LTE化に挑戦(中):

« 【PC】 理想のPC環境を手に入れた | トップページ | 【Venue 8 Pro】 LTE化完了 »